How do I apply 3D LUTs in Adobe Premiere Pro?

You are here:
Estimated reading time: 1 min

Introduction

There are several ways you can apply 3D LUTs in Adobe Premiere Pro. Please note however, that only Premiere Pro CC and above support 3D LUTs natively. In this document we’ll cover two options of applying a 3D LUT to your footage inside Premiere Pro. Please note that Premiere Pro refers to applying a 3D LUT as Lumetri Color.

Adding a Lumetri Color effect to the clip

1. Load your project

2. Open the Effects tab

Effects Tab

3. Go to Video Effects > Color Correction > Lumetri Color

Video Color Correction

Lumetri Color

4. Drag the Lumetri Color effect onto your clip

Drag and Drop Lumetri Color

5. Under Effects Control load the 3D LUT you’d like to apply to your footage. Please note that if you have older versions of Premiere Pro, the interface and steps from this point on may look a bit different but the concept is the same.

6. If you’re loading a Log normalization LUT, go to Basic Correction > Input LUT > Browse and choose the desired log normalization LUT.

Load Log Normalization LUT

7. If you’re loading a creative LUT, go to Creative > Look > Browse and choose the desired creative LUT.

Load Creative LUT

8. Your LUT is applied

Using the Color interface tab (Premiere Pro CC 2015 or later)

1. Load your project

2. Click on the Color interface tab or go to Window > Workspaces > Color or press Alt + Shift + 3.

Premiere Pro Color Tab

3. Select your clip

Select Your Clip

4. If you’re loading a Log normalization LUT, go to Basic Correction > Input LUT > Browse and choose the desired log normalization LUT.

Input LUT

5. If you’re loading a creative LUT, go to Creative > Look > Browse and choose the desired creative LUT.

Creative LUT

Was this article helpful?
Dislike 11
Close
Go top